Dependencies not installable

More information: https://insight.symfony.com/what-we-analyse/composer.dependencies_not_installable

SymfonyInsight was not able to install your Composer dependencies. If you need to customize files or run commands to make it work, you can edit your SymfonyInsight project configuration to override the default "pre_composer_script" and/or "post_composer_script" settings.

Time to fix: about 3 hours
Open Issue Permalink
Collective
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - presta/cms-core-bundle 1.0.0 requires doctrine/phpcr-bundle 1.0.* -> satisfiable by doctrine/phpcr-bundle[1.0.0, 1.0.0-RC1, 1.0.0-alpha1, 1.0.0-alpha2, 1.0.0-alpha3, 1.0.0-alpha4, 1.0.0-beta1, 1.0.0-beta2, 1.0.0-beta3, 1.0.0-beta4, 1.0.x-dev].
    - presta/cms-core-bundle 1.0.0-beta1 requires doctrine/phpcr-bundle 1.0.* -> satisfiable by doctrine/phpcr-bundle[1.0.0, 1.0.0-RC1, 1.0.0-alpha1, 1.0.0-alpha2, 1.0.0-alpha3, 1.0.0-alpha4, 1.0.0-beta1, 1.0.0-beta2, 1.0.0-beta3, 1.0.0-beta4, 1.0.x-dev].
    - presta/cms-core-bundle 1.0.x-dev requires doctrine/phpcr-bundle 1.0.* -> satisfiable by doctrine/phpcr-bundle[1.0.0, 1.0.0-RC1, 1.0.0-alpha1, 1.0.0-alpha2, 1.0.0-alpha3, 1.0.0-alpha4, 1.0.0-beta1, 1.0.0-beta2, 1.0.0-beta3, 1.0.0-beta4, 1.0.x-dev].
    - doctrine/phpcr-bundle 1.0.x-dev requires phpcr/phpcr-implementation 2.1.* -> no matching package found.
    - doctrine/phpcr-bundle 1.0.0-beta4 requires phpcr/phpcr-implementation 2.1.* -> no matching package found.
    - doctrine/phpcr-bundle 1.0.0-beta3 requires phpcr/phpcr-implementation 2.1.* -> no matching package found.
    - doctrine/phpcr-bundle 1.0.0-beta2 requires phpcr/phpcr-implementation 2.1.* -> no matching package found.
    - doctrine/phpcr-bundle 1.0.0-beta1 requires phpcr/phpcr-implementation 2.1.* -> no matching package found.
    - doctrine/phpcr-bundle 1.0.0-alpha4 requires phpcr/phpcr-implementation 2.1.* -> no matching package found.
    - doctrine/phpcr-bundle 1.0.0-alpha3 requires phpcr/phpcr-implementation 2.1.* -> no matching package found.
    - doctrine/phpcr-bundle 1.0.0-alpha2 requires phpcr/phpcr-implementation 2.1.* -> no matching package found.
    - doctrine/phpcr-bundle 1.0.0-alpha1 requires phpcr/phpcr-implementation 2.1.* -> no matching package found.
    - doctrine/phpcr-bundle 1.0.0-RC1 requires phpcr/phpcr-implementation 2.1.* -> no matching package found.
    - doctrine/phpcr-bundle 1.0.0 requires phpcr/phpcr-implementation 2.1.* -> no matching package found.
    - Installation request for presta/cms-core-bundle 1.0.* -> satisfiable by presta/cms-core-bundle[1.0.0, 1.0.0-beta1, 1.0.x-dev].

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Text files should end with a valid new line character. 2

More information: https://insight.symfony.com/what-we-analyse/missing_e_o_l

in .gitignore, line 3
  1. composer.phar
  2. vendor/*
  3. php-cs-fixer.phar

    This file ends with no newline character, or with a different newline character than other files in your project. It won't render properly on a terminal, and it's considered a bad practice.

    Time to fix: about 15 minutes
    Open Issue Permalink
    Last edited by Alain Flaus
in .scrutinizer.yml, line 13
  1. php_analyzer:
  2. filter:
  3. excluded_paths: ["*/Tests/*"]
  4. sensiolabs_security_checker: true
  5. php_pdepend: true
  6. php_code_coverage: false

    This file ends with no newline character, or with a different newline character than other files in your project. It won't render properly on a terminal, and it's considered a bad practice.

    Time to fix: about 15 minutes
    Open Issue Permalink
    Last edited by Alain Flaus