Dependencies not installable

More information: https://insight.symfony.com/what-we-analyse/composer.dependencies_not_installable

SymfonyInsight was not able to install your Composer dependencies. If you need to customize files or run commands to make it work, you can edit your SymfonyInsight project configuration to override the default "pre_composer_script" and/or "post_composer_script" settings.

Time to fix: about 3 hours
Permalink
Collective
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Package operations: 101 installs, 0 updates, 0 removals
  - Installing composer/installers (v1.7.0): Downloading (100%)
  - Installing wikimedia/composer-merge-plugin (v1.4.1): Downloading (100%)
  - Installing kriswallsmith/assetic (v1.0.5): Downloading (100%)
  - Installing robloach/component-installer (0.2.3): Downloading (100%)
  - Installing behat/transliterator (v1.2.0): Downloading (100%)
  - Installing composer/semver (1.5.0): Downloading (100%)
  - Installing dimsemenov/magnific-popup (1.1.0): Downloading (100%)
  - Installing symfony/polyfill-mbstring (v1.12.0): Downloading (100%)
  - Installing symfony/polyfill-ctype (v1.12.0): Downloading (100%)
  - Installing twig/twig (v2.12.1): Downloading (100%)
  - Installing symfony/polyfill-php73 (v1.12.0): Downloading (100%)
  - Installing symfony/polyfill-php72 (v1.12.0): Downloading (100%)
  - Installing symfony/polyfill-intl-idn (v1.12.0): Downloading (100%)
  - Installing symfony/symfony (v4.3.6): Downloading (100%)
  - Installing symfony/polyfill-intl-icu (v1.12.0): Downloading (100%)
  - Installing psr/container (1.0.0): Downloading (100%)
  - Installing psr/cache (1.0.1): Downloading (100%)
  - Installing symfony/contracts (v1.1.7): Downloading (100%)
  - Installing psr/log (1.1.2): Downloading (100%)
  - Installing psr/link (1.0.0): Downloading (100%)
  - Installing fig/link-util (1.0.0): Downloading (100%)
  - Installing doctrine/lexer (1.1.0): Downloading (100%)
  - Installing doctrine/annotations (v1.8.0): Downloading (100%)
  - Installing doctrine/reflection (v1.0.0): Downloading (100%)
  - Installing doctrine/event-manager (v1.0.0): Downloading (100%)
  - Installing doctrine/collections (v1.6.2): Downloading (100%)
  - Installing doctrine/cache (v1.8.1): Downloading (100%)
  - Installing doctrine/persistence (1.1.1): Downloading (100%)
  - Installing jdorn/sql-formatter (v1.2.17): Downloading (100%)
  - Installing doctrine/inflector (v1.3.0): Downloading (100%)
  - Installing doctrine/doctrine-cache-bundle (1.3.5): Downloading (100%)
  - Installing doctrine/dbal (v2.9.2): Downloading (100%)
  - Installing doctrine/doctrine-bundle (1.11.2): Downloading (100%)
  - Installing doctrine/instantiator (1.2.0): Downloading (100%)
  - Installing doctrine/common (v2.11.0): Downloading (100%)
  - Installing doctrine/orm (v2.6.4): Downloading (100%)
  - Installing egulias/email-validator (2.1.11): Downloading (100%)
  - Installing elao/web-profiler-extra-bundle (v2.3.6): Downloading (100%)
  - Installing willdurand/jsonp-callback-validator (v1.1.0): Downloading (100%)
  - Installing friendsofsymfony/jsrouting-bundle (2.4.0): Downloading (100%)
  - Installing guzzlehttp/promises (v1.3.1): Downloading (100%)
  - Installing ralouphie/getallheaders (3.0.3): Downloading (100%)
  - Installing psr/http-message (1.0.1): Downloading (100%)
  - Installing guzzlehttp/psr7 (1.6.1): Downloading (100%)
  - Installing ircmaxell/security-lib (v1.1.0): Downloading (100%)
  - Installing ircmaxell/random-lib (v1.2.0): Downloading (100%)
  - Installing jquery.mmenu (7.3.3): Downloading (100%)
  - Installing jakeasmith/http_build_url (1.0.1): Downloading (100%)
  - Installing jms/i18n-routing-bundle (3.0.3): Downloading (100%)
  - Installing nikic/php-parser (v4.2.5): Downloading (100%)
  - Installing jms/translation-bundle (1.4.4): Downloading (100%)
  - Installing justinrainbow/json-schema (5.2.9): Downloading (100%)
  - Installing knplabs/knp-menu (2.6.0): Downloading (100%)
  - Installing knplabs/knp-menu-bundle (v2.3.0): Downloading (100%)
  - Installing paragonie/random_compat (v9.99.99): Downloading (100%)
  - Installing guzzlehttp/guzzle (6.4.1): Downloading (100%)
  - Installing league/oauth2-client (2.4.1): Downloading (100%)
  - Installing imagine/imagine (1.2.2): Downloading (100%)
  - Installing liip/imagine-bundle (2.2.0): Downloading (100%)
  - Installing matthiasnoback/symfony-console-form (v3.6.0): Downloading (100%)
  - Installing michelf/php-markdown (1.8.0): Downloading (100%)
  - Installing oyejorge/less.php (dev-master 42925c5): Downloading (100%)
  - Installing ezyang/htmlpurifier (dev-master 4faca32): Downloading (100%)
  - Installing phpids/phpids (dev-master dfc1476): Downloading (100%)
  - Installing sensio/framework-extra-bundle (dev-master dfc2c4d): Downloading (100%)
  - Installing composer/ca-bundle (1.2.4): Downloading (100%)
  - Installing sensiolabs/security-checker (v5.0.3): Downloading (100%)
  - Installing gedmo/doctrine-extensions (v2.4.37): Downloading (100%)
  - Installing stof/doctrine-extensions-bundle (v1.3.0): Downloading (100%)
  - Installing symfony/maker-bundle (v1.14.0): Downloading (100%)
  - Installing monolog/monolog (1.25.1): Downloading (100%)
  - Installing symfony/monolog-bundle (v3.4.0): Downloading (100%)
  - Installing symfony/polyfill-iconv (v1.12.0): Downloading (100%)
  - Installing swiftmailer/swiftmailer (v6.2.1): Downloading (100%)
  - Installing symfony/swiftmailer-bundle (v3.3.0): Downloading (100%)
  - Installing twig/extensions (v1.5.4): Downloading (100%)
  - Installing components/jquery (3.4.1): Downloading (100%)
  - Installing vakata/jstree (3.3.8): Downloading (100%)
  - Installing willdurand/js-translation-bundle (2.6.6): Downloading (100%)
  - Installing zikula/andreas08-theme (3.1.1): Downloading (100%)
  - Installing components/bootstrap (3.4.1): Downloading (100%)
  - Installing zikula/bootstrap-bundle (3.0.1): Downloading (100%)
  - Installing zikula/filesystem (1.0.0): Downloading (100%)
  - Installing components/font-awesome (4.7.0): Downloading (100%)
  - Installing zikula/fontawesome-bundle (4.1.0): Downloading (100%)
  - Installing zikula/generator-bundle (3.0.1): Downloading (100%)
  - Installing zikula/jquery-bundle (2.0.0): Downloading (100%)
  - Installing components/jqueryui (1.12.1): Downloading (100%)
  - Installing zikula/jquery-ui-bundle (1.0.0): Downloading (100%)
  - Installing zikula/legal-module (3.2.5): Downloading (100%)
  - Installing league/oauth2-linkedin (4.1.1): Downloading (100%)
  - Installing league/oauth2-instagram (2.0.0): Downloading (100%)
  - Installing league/oauth2-google (3.0.1): Downloading (100%)
  - Installing league/oauth2-github (2.0.0): Downloading (100%)
  - Installing league/oauth2-facebook (2.0.1): Downloading (100%)
  - Installing zikula/oauth-module (1.1.1): Downloading (100%)
  - Installing zikula/pagelock-module (1.3.5): Downloading (100%)
  - Installing zikula/profile-module (3.1.10): Downloading (100%)
  - Installing zikula/seabreeze-theme (4.1.2): Downloading (100%)
  - Installing zikula/wizard (3.0.1): Downloading (100%)
  - Installing symfony/phpunit-bridge (v4.3.6): Downloading (100%)
symfony/contracts suggests installing psr/event-dispatcher (When using the EventDispatcher contracts)
symfony/contracts suggests installing symfony/cache-implementation
symfony/contracts suggests installing symfony/event-dispatcher-implementation
symfony/contracts suggests installing symfony/http-client-implementation
symfony/contracts suggests installing symfony/service-implementation
symfony/contracts suggests installing symfony/translation-implementation
doctrine/cache suggests installing alcaeus/mongo-php-adapter (Required to use legacy MongoDB driver)
doctrine/doctrine-cache-bundle suggests installing symfony/security-acl (For using this bundle to cache ACLs)
guzzlehttp/psr7 suggests installing zendframework/zend-httphandlerrunner (Emit PSR-7 responses)
paragonie/random_compat suggests installing ext-libsodium (Provides a modern crypto API that can be used to generate random bytes.)
imagine/imagine suggests installing ext-gmagick (to use the Gmagick implementation)
imagine/imagine suggests installing ext-imagick (to use the Imagick implementation)
liip/imagine-bundle suggests installing alcaeus/mongo-php-adapter (required on PHP >= 7.0 to use mongo components with mongodb extension)
liip/imagine-bundle suggests installing amazonwebservices/aws-sdk-for-php (required to use AWS version 1 cache resolver)
liip/imagine-bundle suggests installing aws/aws-sdk-php (required to use AWS version 2/3 cache resolver)
liip/imagine-bundle suggests installing doctrine/mongodb-odm (required to use mongodb-backed doctrine components)
liip/imagine-bundle suggests installing enqueue/enqueue-bundle (^0.9 add if you like to process images in background)
liip/imagine-bundle suggests installing ext-gmagick (required to use gmagick driver)
liip/imagine-bundle suggests installing ext-imagick (required to use imagick driver)
liip/imagine-bundle suggests installing ext-mongo (required for mongodb components on PHP <7.0)
liip/imagine-bundle suggests installing ext-mongodb (required for mongodb components on PHP >=7.0)
liip/imagine-bundle suggests installing league/flysystem (required to use FlySystem data loader or cache resolver)
sensio/framework-extra-bundle suggests installing symfony/psr-http-message-bridge (To use the PSR-7 converters)
gedmo/doctrine-extensions suggests installing doctrine/mongodb-odm (to use the extensions with the MongoDB ODM)
stof/doctrine-extensions-bundle suggests installing doctrine/mongodb-odm-bundle (to use the MongoDB ODM extensions)
monolog/monolog suggests installing aws/aws-sdk-php (Allow sending log messages to AWS services like DynamoDB)
monolog/monolog suggests installing doctrine/couchdb (Allow sending log messages to a CouchDB server)
monolog/monolog suggests installing ext-amqp (Allow sending log messages to an AMQP server (1.0+ required))
monolog/monolog suggests installing ext-mongo (Allow sending log messages to a MongoDB server)
monolog/monolog suggests installing graylog2/gelf-php (Allow sending log messages to a GrayLog2 server)
monolog/monolog suggests installing mongodb/mongodb (Allow sending log messages to a MongoDB server via PHP Driver)
monolog/monolog suggests installing php-amqplib/php-amqplib (Allow sending log messages to an AMQP server using php-amqplib)
monolog/monolog suggests installing php-console/php-console (Allow sending log messages to Google Chrome)
monolog/monolog suggests installing rollbar/rollbar (Allow sending log messages to Rollbar)
monolog/monolog suggests installing ruflin/elastica (Allow sending log messages to an Elastic Search server)
monolog/monolog suggests installing sentry/sentry (Allow sending log messages to a Sentry server)
swiftmailer/swiftmailer suggests installing true/punycode (Needed to support internationalized email addresses, if ext-intl is not installed)
components/bootstrap suggests installing components/bootstrap-default (Provide a theme for Bootstrap as components/bootstrap only provides the CSS as file assets)
Generating optimized autoload files
> ComponentInstaller\Installer::postAutoloadDump
Compiling component files
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 2
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 3
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 4
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 5
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 6
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 7
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 8
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 9
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 10
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 11
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 12
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 13
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 14
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 15
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 16
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 17
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 18
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 19
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 20
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 21
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 22
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 23
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 24
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 25
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 26
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 27
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 28
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 29
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 30
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 31
    - This package requires php >=7.2.0 but your PHP version (7.1.20) does not satisfy that requirement.
  Problem 32
    - doctrine/lexer 1.1.0 requires php ^7.2 -> your PHP version (7.1.20) does not satisfy that requirement.
    - doctrine/lexer 1.1.0 requires php ^7.2 -> your PHP version (7.1.20) does not satisfy that requirement.
    - Installation request for doctrine/lexer 1.1.0 -> satisfiable by doctrine/lexer[1.1.0].


Fatal error: Class 'Sensio\Bundle\DistributionBundle\Composer\ScriptHandler' not found in /home/foobar/code/src/lib/Zikula/Composer/CopyRequirementsFile.php on line 20